• ¬°Welcome to the WhatPulse Forums!
Hello There, Guest! Login Register

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Title: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Threaded Mode

This has started happening on two different computers both running Debian Testing:

Whatpulse 2.7.1 fails with the message "AES functions not available. Is OpenSSL library present?"

Normally, this seems to be a failure to have libssl-dev installed. I have libssl-dev 1.1.0 installed.

[Edited] I have downgraded to libssl-dev 1.0.1 and Whatpulse runs perfectly again - but to continue counting keystrokes, I had to pulse, then delete my local data files and start afresh.

I'm getting exactly the same issue on Kali Linux. Not much point in reverting to libssl-dev 1.0.1 either because of dependencies.
I'm having the same issue, also on debian testing. The worst thing is that since whatpulse doesn't run, I won't be notified when they'll release 2.7.2 which will hopefully fix the error.
The latest debian version still seems to be used libssl 1.0.0. Same goes for Ubuntu. This means the next client version will still be linked to libssl 1.0.0.

What happens when you symlink the new libssl.so.1.1.0 to the old libssl.so.1.0.0?
Problem i have is when i upgrade Kali OS it installs libssl-dev 1.1.0, will have to see if i can install 1.0.0 alongside 1.1.0 without breaking stuff

Possibly Related Threads…
Thread Author Replies Views Last Post
  Cannot log in on Whatpulse client riddl3r 0 370 01-26-2022, 06:10 AM
Last Post: riddl3r
  WhatPulse slow loading, massive HDD usage Redirect Left 0 195 01-11-2022, 03:34 AM
Last Post: Redirect Left
  Whatpulse restarting several times cavveman 2 250 01-10-2022, 05:28 PM
Last Post: cavveman
  I can't use new versions "WhatPulse". Fluttermina 9 727 01-09-2022, 02:31 PM
Last Post: Fluttermina
  Whatpulse is not tracking anything on linux Xabec 2 775 11-29-2021, 09:08 AM
Last Post: Xabec
  Whatpulse client backup: Access is denied. Galaxied 1 796 11-28-2021, 10:31 AM
Last Post: smitmartijn
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 791 11-03-2021, 10:29 PM
Last Post: Code-E
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 622 09-29-2021, 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,754 09-10-2021, 11:30 AM
Last Post: kitliasteele
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 14,522 08-23-2021, 09:45 PM
Last Post: Tealdragon204

Forum Jump:

Browsing: 2 Guest(s)