Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WhatPulse 2.0 drains all CPU
#1
Yesterday I've updated WhatPulse to the new version, but now I can't have it opened. The computer became to slow. I can't open any game, and even browser can't open a simple page (like google) in less than a minute...

If I open the Task Manager, the WhatPulse aplication is "taking care" of more than 90% of CPU.

Did anyone noticed the same?
#2
Anyone?
#3
What exactly are your specs?
#4
Intel C2D E6600 (2.4GHz)
8GB RAM
ATI Radeon HD6870 (1GB GDDR5)

I know the processor is not very good, but with the WhatPulse's previous version I don't have a single problem...

I tried to unmonitor network traffic and system uptime but it keeps draining all the CPU...
#5
WhatPulse should not be (and indeed can't) use all of your CPU if you're running a Core 2 Duo; WhatPulse can only run on one thread. Check via task manager how much CPU it's actually using.
#6
You could also try to disable network stats, maybe winpcap is doing something weird.
#7
OS?

Please first try disabling network statistics to see if the problems persists. If that doesn't help, disable input statstics.

That would tell us more to what exactly the problem is.
#8
It happens from time to time on my machines, from lowly netbooks to the mega 32 thread rigs. I usually have to wait until it lets me open Task Manager and exit it that way.

Ideally though WhatPulse should be on the lowest CPU priority anyway from install.
#9
Yea, I've used ProcessLasso and set it to one thread and idle/low priority and it still uses up that whole thread it's running on.

I've observed that it happens mainly at boot up or if the system is under a heavy load (on two of my machines running Windows). Tho on my main system it's cpu usage climbs above 10% periodically throughout the day even at idle or light loads like playing a movie; these smaller spikes I would attribute to the network stats, but when it climbs above 20-30% for me WP is usually completely hung up and I have to kill the process.


Possibly Related Threads…
Thread Author Replies Views Last Post
  WhatPulse slow loading, massive HDD usage Redirect Left 0 148 01-11-2022, 03:34 AM
Last Post: Redirect Left
  Whatpulse restarting several times cavveman 2 211 01-10-2022, 05:28 PM
Last Post: cavveman
  I can't use new versions "WhatPulse". Fluttermina 9 634 01-09-2022, 02:31 PM
Last Post: Fluttermina
  Whatpulse is not tracking anything on linux Xabec 2 715 11-29-2021, 09:08 AM
Last Post: Xabec
  Whatpulse client backup: Access is denied. Galaxied 1 727 11-28-2021, 10:31 AM
Last Post: smitmartijn
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 740 11-03-2021, 10:29 PM
Last Post: Code-E
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 595 09-29-2021, 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,699 09-10-2021, 11:30 AM
Last Post: kitliasteele
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 14,412 08-23-2021, 09:45 PM
Last Post: Tealdragon204
  Whatpulse doesn't track internet up/down correctly on gigibit internet Deuss 2 1,014 08-19-2021, 08:32 PM
Last Post: lvh1

Forum Jump:


Users browsing this thread: 1 Guest(s)