WhatPulse Forums » Support » Client software v » Error regarding missing DLL Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error regarding missing DLL
01-17-2021, 03:44 PM
Post: #1
Error regarding missing DLL
I just updated to v3.1 and now whatpulse won't work Sad I attached a screencap of the error. I tried reinstalling but it didn't help. Please help soon, I don't like not having my stats tracked... Sad


Attached File(s)
.png  whatpulseError.png (Size: 141.08 KB / Downloads: 159)
Find all posts by this user
Quote this message in a reply
01-18-2021, 10:02 AM (This post was last modified: 01-18-2021 11:18 AM by TehMoff.)
Post: #2
RE: Error regarding missing DLL
Currently having the same issue, done a /sfc scannow in cmd without success, tried reinstalling WhatPulse which didn't help.
I think it's something related to all those "Microsoft Visual C++" redistributables, so I'm about to uninstall/reinstall all of them to see what happens.

I also searched my other computer for this dll, and it doesn't even have it - but WhatPulse 3.1 works fine there, weird!

Alright, uninstalled all the Redist stuff, rebooted, reinstalled WhatPulse which in turn installed Microsoft Visual C++ Redistributable (x86) 14.0.23026 and STILL had the same very same error :|

If I uninstall the one redist that WhatPulse installed for me, and try to run WhatPulse, it says MSVCP140.dll (note: not MSCVCP140_1.dll, if its of importance) is missing. The next prompt says the code execution cannot proceed because VCRUNTIME140.dll was not found, the third prompt is the same as the second. The forth prompt goes back to missing MSVCP140.dll, then there are no more.

Finally, the MSVCP140.dll seems to be related to the 2015 version of the redists ( https://www.groovypost.com/howto/fix-vis...indows-10/ )
I downloaded the install for both x86 and x64 from Microsoft, same issue.

Currently out of ideas, went back to 3.0.

The computer is running Windows 10 Pro x64 build 19042.746 (20H2)
Find all posts by this user
Quote this message in a reply
01-18-2021, 05:22 PM
Post: #3
RE: Error regarding missing DLL
I have the same problem after installing v 3.1
Find all posts by this user
Quote this message in a reply
01-19-2021, 12:50 PM
Post: #4
RE: Error regarding missing DLL
Do you guys have maybe mirror to version 3.0?
Find all posts by this user
Quote this message in a reply
01-19-2021, 01:27 PM
Post: #5
RE: Error regarding missing DLL
Same problem here
Find all posts by this user
Quote this message in a reply
01-19-2021, 04:27 PM
Post: #6
RE: Error regarding missing DLL
(01-19-2021 12:50 PM)StrozeR Wrote:  Do you guys have maybe mirror to version 3.0?

IDK about v3.0 but here is the last beta release, which I think is much the same as v3.0
https://whatpulse.org/forums/showthread.php?tid=7894
Find all posts by this user
Quote this message in a reply
01-19-2021, 07:48 PM
Post: #7
RE: Error regarding missing DLL
(01-19-2021 04:27 PM)TheIceMage Wrote:  
(01-19-2021 12:50 PM)StrozeR Wrote:  Do you guys have maybe mirror to version 3.0?

IDK about v3.0 but here is the last beta release, which I think is much the same as v3.0
https://whatpulse.org/forums/showthread.php?tid=7894

thanks for the mirror! Will have to use this until it's fixed
Find all posts by this user
Quote this message in a reply
01-20-2021, 11:22 AM
Post: #8
RE: Error regarding missing DLL
Hi, please re-download the client and try again. There was an issue with a dependency (Visual Studio Redistributable) that might've caused above DDL error.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Pulse: Error while talking to website Sylverblack 2 200 10-02-2021 05:20 PM
Last Post: ssnake42069
Question SSL Handshake Error dkuebric 15 6,684 09-27-2021 08:34 AM
Last Post: smitmartijn
  WhatPulse error on Linux (Elementary-OS 6) Suxhe 0 439 06-13-2021 10:56 PM
Last Post: Suxhe
  Getting a lot of application error cavveman 0 803 01-23-2021 09:01 AM
Last Post: cavveman
  Error: "Network access is disabled." Jourei 5 1,803 01-20-2021 07:01 AM
Last Post: penguin2233
  OS X Big Sur SSL error firegate666 3 1,835 11-30-2020 10:03 AM
Last Post: smitmartijn
  Missing input! Contact the developers. MrCraig 1 2,362 02-12-2020 01:03 PM
Last Post: MrCraig
Question [Win7x64 WP2.5] Error while pulsing: "Wrong Password! Try again." Diamundo 9 8,637 01-18-2020 12:08 PM
Last Post: Megachip
  API documentation missing /1/v1/realtime Sarah.Walsh 0 2,363 12-05-2019 12:40 AM
Last Post: Sarah.Walsh
  Server error: Missing input! with whatpulse 2.8.4 on Win10 Franck.Dernoncourt 3 3,649 09-24-2019 10:56 PM
Last Post: kolah

Forum Jump:


User(s) browsing this thread: 1 Guest(s)