WhatPulse Forums
[Edited] Whatpulse does not work with libssl-dev 1.1.0 - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: [Edited] Whatpulse does not work with libssl-dev 1.1.0 (/showthread.php?tid=7783)



[Edited] Whatpulse does not work with libssl-dev 1.1.0 - jhepburn - 12-12-2016 09:57 PM

Greetings,

This has started happening on two different computers both running Debian Testing:

Whatpulse 2.7.1 fails with the message "AES functions not available. Is OpenSSL library present?"

Normally, this seems to be a failure to have libssl-dev installed. I have libssl-dev 1.1.0 installed.

[Edited] I have downgraded to libssl-dev 1.0.1 and Whatpulse runs perfectly again - but to continue counting keystrokes, I had to pulse, then delete my local data files and start afresh.

Jonathan


RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0 - swissboney3 - 01-08-2017 09:07 PM

I'm getting exactly the same issue on Kali Linux. Not much point in reverting to libssl-dev 1.0.1 either because of dependencies.


RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0 - pinabaszfasz - 01-09-2017 05:44 PM

I'm having the same issue, also on debian testing. The worst thing is that since whatpulse doesn't run, I won't be notified when they'll release 2.7.2 which will hopefully fix the error.


RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0 - smitmartijn - 02-27-2017 05:26 PM

The latest debian version still seems to be used libssl 1.0.0. Same goes for Ubuntu. This means the next client version will still be linked to libssl 1.0.0.

What happens when you symlink the new libssl.so.1.1.0 to the old libssl.so.1.0.0?


RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0 - swissboney3 - 03-07-2017 11:11 PM

Problem i have is when i upgrade Kali OS it installs libssl-dev 1.1.0, will have to see if i can install 1.0.0 alongside 1.1.0 without breaking stuff